Verification is currently underway for the maintenance items.
Posted Feb 23, 2026 - 04:16 CST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 23, 2026 - 02:00 CST
Scheduled
We will be performing scheduled maintenance on Monday, February 23, starting at 3:00 AM ET / 12:00 AM PT, lasting for up to 3 hours. Team sites will be offline during this time. Visit help.swimtopia.com for details.
Posted Feb 19, 2026 - 16:06 CST
This scheduled maintenance affected: SwimTopia customer sites, Meet Maestro, SwimTopia Mobile and Background processes (Email processing, Background data processing, USA Swimming SWIMS API).